•   欢迎来到21NN网.
  •   请记住本站网址www.21nn.cn

centos怎样更新php【php问题】,centos,更新,php

摘要: 1、搜检当前装置的PHP包yumlistinstalled|grepphp如果有装置的PHP包,先删除他们yumremovephp.x86_64php-cli.x86_...

1、搜检当前装置的PHP包

yum list installed | grep php

如果有装置的PHP包,先删除他们

yum remove php.x86_64 php-cli.x86_64 php-common.x86_64 php-gd.x86_64 php-ldap.x86_64 
php-mbstring.x86_64 php-mcrypt.x86_64 php-mysql.x86_64 php-pdo.x86_64

2、设置yum源(6.8版本)

rpm -Uvh http://ftp.iij.ad.jp/pub/linux/fedora/epel/6/x86_64/epel-release-6-8.noarch.rpm
rpm -Uvh http://rpms.famillecollet.com/enterprise/remi-release-6.rpm
yum源(7.0版本)
yum install epel-release
rpm -ivh http://rpms.famillecollet.com/enterprise/remi-release-7.rpm

3、装置PHP5.6.x

yum install --enablerepo=remi --enablerepo=remi-php56 php php-opcache php-devel 
php-mbstring php-mcrypt php-mysqlnd php-phpunit-PHPUnit php-pecl-xdebug php-pecl-xhprof

用PHP敕令检察版本:

# php --version
PHP 5.6.0 (cli) (built: Sep  3 2014 19:51:31)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2014 Zend Technologies
with Zend OPcache v7.0.4-dev, Copyright (c) 1999-2014, by Zend Technologies
with Xdebug v2.2.5, Copyright (c) 2002-2014, by Derick Rethans

4、装置PHP-fpm

yum install --enablerepo=remi --enablerepo=remi-php56 php-fpm

引荐教程:PHP视频教程

以上就是centos怎样更新php的细致内容,更多请关注ki4网别的相干文章!

分享到:

发表评论

评论列表

还没有评论,快来说点什么吧~

公众号二维码

微信公众号